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OpsCenter stalls on "Loading OpsCenter..." when using Google Chrome

Summary

When attempting to connect to the OpsCenter web interface in Google Chrome, the web interface hangs on a black screen and displays the words "Loading OpsCenter..." This is known to occur on laptops with a touch screen.

Symptoms

OpsCenter will not load the dashboard. Opening JavaScript Console in Chrome will display the error messages in the image below.

dojo_errors.png

Cause

This has been identified as rooted in Google Chrome calling for touchscreen modules in the Dojo toolkit that are not packaged with OpsCenter.

Workaround

To resolve this issue, the default touchscreen handling in Chrome, normally set to "Automatic," can be set to "Disabled" by navigating to the URL 'chrome://flags' and scrolling to the appropriate flag row as seen below. After this, a relaunch of Chrome is required. Alternatively, a different browser can be used, as this has only been reproducible in Google Chrome.

Disable_touch_chrome_opscenter.PNG

Solution

Datastax is tracking resolution of this issue on internal JIRA OPSC-1177. This is expected to be fixed in an upcoming version of OpsCenter, but which version will include the fix has not been finalized as of the writing of this article. The article will be updated once the OpsCenter version with the fix is decided.

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