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Using special characters in JMX passwords causes agent connectivity issues

Summary

Opscenter agent fails to connect to the local cassandra node via JMX

Symptoms

When JMX authentication is enabled on a Cassandra cluster, the agent fails to connect when a complex password contains some special characters. The following entries are reported in the agent.log

INFO [StompConnection receiver] 2015-06-17 11:20:03,542 New JMX connection (myserver1.7199) 
WARN [StompConnection receiver] 2015-06-17 11:20:03,558 Error when trying to match our local token: java.lang.SecurityException: Authentication failed! Invalid username or password 

Cause

This is a known issue, and covered in the following internal jira:

OPSC-5738 - Using special characters in JMX passwords causes agent connectivity issues

Workaround

Change the JMX password to exclude the special characters.

Solution

At the time of writing this article OPSC-5738 was not resolved.

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Comments

  • Avatar
    Abhishek Darak

    Is this Fixed for latest versions of DSE and Opscenter.

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