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OpsCenter agent not starting fully when Kerberos authentication is used

Overview

When using Kerberos authentication from the OpsCenter agent to DSE. The agent would start but not connect to the OpsCenter process, therefore no metrics would show in the OpsCenter dashboard for that node

Symptoms

The following error would appear just after agent start in the agent.log

 ERROR [async-dispatch-2] 2016-11-04 20:44:50,301 {:type :opsagent.environment.utils/env-not-collected, :path [:paths :config-paths :agent-config], :message [BUG] Environment information accessed before it got collected. Requested path: [:paths :config-paths :agent-config]} Error starting DynamicEnvironmentComponent.

Cause

This issue was identified and in the following internal jira

OPSC-10860 - Setting “kerberos_keytab_location” and “kerberos_client_principal” in agent config prevents agent from starting

Workaround

Disabling the Kerberos authentication for the agent into DSE is an option. Note that you will need to have an alternative authentication method such as internal or ldap in your dse.yaml file. See the following documentation on Unified authentication

To disable kerberos in the agent, leave the following address.yaml parameters empty: 

kerberos_service:
kerberos_keytab_location:
kerberos_client_principal:

Solution

Upgrade to a version of OpsCenter that contains the fix for OPSC-10860 (or later) as it becomes available.

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